use strict;
my $str = 'THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
123 WDD2052041F133125 - CORRECT VIN
44 WDD 169 007-1J-236589 - ALSO CORRECT VIN
1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 - INCORRECT VIN
AND THIS IS JUST CAPS TEXT FOR THE TEST
WDD2052041F133125
WDD 2052041F133125 - VIN WITH TAB
!! WDD2052041F133125
- TWO VINS CODES ONE BY ONE
W D - - - D 2 0 5 2---0 4 1 F-1 3-3125
- MULTIPLE DELIMITERS
X WDD
2052041F133125
- MULTILINE DELIMITERS
(WDD2052041F133125)';
my $regex = qr/Invoice ((?:[0-9]){8})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}