#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\.(js\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\?.*|png\?.*|jpg\?.*|svg\?.*|bmp\?.*|css\?.*|jpeg\?.*|pdf\?.*|ico\?.*|eot\?.*|woff\?.*|woff2\?.*|axd\?.*|ttf\?.*|otf\?.*)$"
Local $sString = "https://i.dell.com/sites/csimages/UberHomePage_Imagery/all/keyboard-mouse-icon.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")