using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.(js\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\?.*|png\?.*|jpg\?.*|svg\?.*|bmp\?.*|css\?.*|jpeg\?.*|pdf\?.*|ico\?.*|eot\?.*|woff\?.*|woff2\?.*|axd\?.*|ttf\?.*|otf\?.*)$";
string input = @"https://i.dell.com/sites/csimages/UberHomePage_Imagery/all/keyboard-mouse-icon.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}