re = /.*\.(js\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\?.*|png\?.*|jpg\?.*|svg\?.*|bmp\?.*|css\?.*|jpeg\?.*|pdf\?.*|ico\?.*|eot\?.*|woff\?.*|woff2\?.*|axd\?.*|ttf\?.*|otf\?.*)$/m
str = 'https://i.dell.com/sites/csimages/UberHomePage_Imagery/all/keyboard-mouse-icon.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end