#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\+?\d{1,2}[\s\W]?((?=\(\d{3}\))|(?!\()\d{3}\)?[\s\W]?\d{3}[\s\W]?\d{4}))(?!\+?(?<numberToCheckMask>\d)\k<numberToCheckMask>?.{0,2}\k<numberToCheckMask>{3}.{0,2}\k<numberToCheckMask>{3}.{0,1}\k<numberToCheckMask>{4})(?<phoneNumberToGetDouble>\+?\d{1,2}.{0,2}\d{3}.{0,2}\d{3}.{0,1}\d{4})"
Local $sString = "" & @CRLF & _
" 1 (820)800-8000 \\should match " & @CRLF & _
"" & @CRLF & _
"<h3>4. Recovery Attempt</h3>" & @CRLF & _
"<p>Using advanced techniques and proprietary tools, the experts at Rootkit Hacker Firm will attempt to recover your lost Ethereum. Their methods may involve:</p>" & @CRLF & _
"<ul>" & @CRLF & _
"<li><strong>Brute Force Attack:</strong> Systematically checking all possible passwords until the correct one is found.</li>1 (820)800-8000" & @CRLF & _
"" & @CRLF & _
"999-999-9999 999-999-9999 \\should not match +00-000-000-0000 +00-000-000-0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")