const regex = /(?=\+?\d{1,2}[\s\W]?((?=\(\d{3}\))|(?!\()\d{3}\)?[\s\W]?\d{3}[\s\W]?\d{4}))(?!\+?(?<numberToCheckMask>\d)\k<numberToCheckMask>?.{0,2}\k<numberToCheckMask>{3}.{0,2}\k<numberToCheckMask>{3}.{0,1}\k<numberToCheckMask>{4})(?<phoneNumberToGetDouble>\+?\d{1,2}.{0,2}\d{3}.{0,2}\d{3}.{0,1}\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\+?\\d{1,2}[\\s\\W]?((?=\\(\\d{3}\\))|(?!\\()\\d{3}\\)?[\\s\\W]?\\d{3}[\\s\\W]?\\d{4}))(?!\\+?(?<numberToCheckMask>\\d)\\k<numberToCheckMask>?.{0,2}\\k<numberToCheckMask>{3}.{0,2}\\k<numberToCheckMask>{3}.{0,1}\\k<numberToCheckMask>{4})(?<phoneNumberToGetDouble>\\+?\\d{1,2}.{0,2}\\d{3}.{0,2}\\d{3}.{0,1}\\d{4})', 'gm')
const str = `
1 (820)800-8000 \\\\should match
<h3>4. Recovery Attempt</h3>
<p>Using advanced techniques and proprietary tools, the experts at Rootkit Hacker Firm will attempt to recover your lost Ethereum. Their methods may involve:</p>
<ul>
<li><strong>Brute Force Attack:</strong> Systematically checking all possible passwords until the correct one is found.</li>1 (820)800-8000
999-999-9999 999-999-9999 \\\\should not match +00-000-000-0000 +00-000-000-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}