import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\+?\\d{1,2}[\\s\\W]?((?=\\(\\d{3}\\))|(?!\\()\\d{3}\\)?[\\s\\W]?\\d{3}[\\s\\W]?\\d{4}))(?!\\+?(?<numberToCheckMask>\\d)\\k<numberToCheckMask>?.{0,2}\\k<numberToCheckMask>{3}.{0,2}\\k<numberToCheckMask>{3}.{0,1}\\k<numberToCheckMask>{4})(?<phoneNumberToGetDouble>\\+?\\d{1,2}.{0,2}\\d{3}.{0,2}\\d{3}.{0,1}\\d{4})";
final String string = "\n"
+ " 1 (820)800-8000 \\\\should match \n\n"
+ "<h3>4. Recovery Attempt</h3>\n"
+ "<p>Using advanced techniques and proprietary tools, the experts at Rootkit Hacker Firm will attempt to recover your lost Ethereum. Their methods may involve:</p>\n"
+ "<ul>\n"
+ "<li><strong>Brute Force Attack:</strong> Systematically checking all possible passwords until the correct one is found.</li>1 (820)800-8000\n\n"
+ "999-999-9999 999-999-9999 \\\\should not match +00-000-000-0000 +00-000-000-0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}