#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)core\.\d*"
Local $sString = "303488 -rw------- 1 oagmgr oinstall 596971520 May 10 15:54 core.10081 " & @CRLF & _
"271392 -rw------- 1 oagmgr oinstall 543047680 Aug 16 09:59 core.1708 " & @CRLF & _
"310616 -rw------- 1 oagmgr oinstall 621223936 Jul 29 09:05 core.21813 " & @CRLF & _
"261296 -rw------- 1 oagmgr oinstall 524054528 Sep 4 08:29 core.25532 " & @CRLF & _
"292500 -rw------- 1 oagmgr oinstall 469028864 Jun 25 19:45 core.32008 " & @CRLF & _
"291580 -rw------- 1 oagmgr oinstall 600080384 Jul 11 22:08 core.7981 " & @CRLF & _
"365072 -rw------- 1 oagmgr oinstall 484425728 Jun 2 14:08 core.8238 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 24 -rw-r--r-- 1 oagmgr oinstall 23606 Aug 16 09:59 hs_err_pid1708.log " & @CRLF & _
" 24 -rw-r--r-- 1 oagmgr oinstall 23436 Apr 4 21:19 hs_err_pid18984.log " & @CRLF & _
" 24 -rw-r--r-- 1 oagmgr oinstall 23421 Sep 4 08:29 hs_err_pid25532.log " & @CRLF & _
" 24 -rw-r--r-- 1 oagmgr oinstall 23497 Jul 11 22:08 hs_err_pid7981.log " & @CRLF & _
" 24 -rw-r--r-- 1 oagmgr oinstall 24080 Jun 2 14:08 hs_err_pid8238.log "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")