import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "core\\.\\d*";
final String string = "303488 -rw------- 1 oagmgr oinstall 596971520 May 10 15:54 core.10081 \n"
+ "271392 -rw------- 1 oagmgr oinstall 543047680 Aug 16 09:59 core.1708 \n"
+ "310616 -rw------- 1 oagmgr oinstall 621223936 Jul 29 09:05 core.21813 \n"
+ "261296 -rw------- 1 oagmgr oinstall 524054528 Sep 4 08:29 core.25532 \n"
+ "292500 -rw------- 1 oagmgr oinstall 469028864 Jun 25 19:45 core.32008 \n"
+ "291580 -rw------- 1 oagmgr oinstall 600080384 Jul 11 22:08 core.7981 \n"
+ "365072 -rw------- 1 oagmgr oinstall 484425728 Jun 2 14:08 core.8238 \n\n\n"
+ " 24 -rw-r--r-- 1 oagmgr oinstall 23606 Aug 16 09:59 hs_err_pid1708.log \n"
+ " 24 -rw-r--r-- 1 oagmgr oinstall 23436 Apr 4 21:19 hs_err_pid18984.log \n"
+ " 24 -rw-r--r-- 1 oagmgr oinstall 23421 Sep 4 08:29 hs_err_pid25532.log \n"
+ " 24 -rw-r--r-- 1 oagmgr oinstall 23497 Jul 11 22:08 hs_err_pid7981.log \n"
+ " 24 -rw-r--r-- 1 oagmgr oinstall 24080 Jun 2 14:08 hs_err_pid8238.log ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}