import Foundation
let pattern = #"core\.\d*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
303488 -rw------- 1 oagmgr oinstall 596971520 May 10 15:54 core.10081
271392 -rw------- 1 oagmgr oinstall 543047680 Aug 16 09:59 core.1708
310616 -rw------- 1 oagmgr oinstall 621223936 Jul 29 09:05 core.21813
261296 -rw------- 1 oagmgr oinstall 524054528 Sep 4 08:29 core.25532
292500 -rw------- 1 oagmgr oinstall 469028864 Jun 25 19:45 core.32008
291580 -rw------- 1 oagmgr oinstall 600080384 Jul 11 22:08 core.7981
365072 -rw------- 1 oagmgr oinstall 484425728 Jun 2 14:08 core.8238
24 -rw-r--r-- 1 oagmgr oinstall 23606 Aug 16 09:59 hs_err_pid1708.log
24 -rw-r--r-- 1 oagmgr oinstall 23436 Apr 4 21:19 hs_err_pid18984.log
24 -rw-r--r-- 1 oagmgr oinstall 23421 Sep 4 08:29 hs_err_pid25532.log
24 -rw-r--r-- 1 oagmgr oinstall 23497 Jul 11 22:08 hs_err_pid7981.log
24 -rw-r--r-- 1 oagmgr oinstall 24080 Jun 2 14:08 hs_err_pid8238.log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)