import re
regex = re.compile(r"core\.\d*", flags=re.MULTILINE)
test_str = ("303488 -rw------- 1 oagmgr oinstall 596971520 May 10 15:54 core.10081 \n"
"271392 -rw------- 1 oagmgr oinstall 543047680 Aug 16 09:59 core.1708 \n"
"310616 -rw------- 1 oagmgr oinstall 621223936 Jul 29 09:05 core.21813 \n"
"261296 -rw------- 1 oagmgr oinstall 524054528 Sep 4 08:29 core.25532 \n"
"292500 -rw------- 1 oagmgr oinstall 469028864 Jun 25 19:45 core.32008 \n"
"291580 -rw------- 1 oagmgr oinstall 600080384 Jul 11 22:08 core.7981 \n"
"365072 -rw------- 1 oagmgr oinstall 484425728 Jun 2 14:08 core.8238 \n\n\n"
" 24 -rw-r--r-- 1 oagmgr oinstall 23606 Aug 16 09:59 hs_err_pid1708.log \n"
" 24 -rw-r--r-- 1 oagmgr oinstall 23436 Apr 4 21:19 hs_err_pid18984.log \n"
" 24 -rw-r--r-- 1 oagmgr oinstall 23421 Sep 4 08:29 hs_err_pid25532.log \n"
" 24 -rw-r--r-- 1 oagmgr oinstall 23497 Jul 11 22:08 hs_err_pid7981.log \n"
" 24 -rw-r--r-- 1 oagmgr oinstall 24080 Jun 2 14:08 hs_err_pid8238.log ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")