#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d\d(?=\S*?[A-Z]\S*?\s)[A-Z0-9]{4}\s"
Local $sString = "AT exempt acc to ยงยง 4 Nr. 1A UStG iVm 6 USTG" & @CRLF & _
" 254,49/100L 977,23" & @CRLF & _
"159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%" & @CRLF & _
"Commodity Code :" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"159C5F Magnatec St-St 0W-30 D, 20L E4" & @CRLF & _
"159432 Magnatec St-St 0W-30 D, 20L E4 --> Number only." & @CRLF & _
"1AAAAA Magnatec St-St 0W-30 D, 20L E4 --> Starts with one digit."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")