const regex = /\b\d\d(?=\S*?[A-Z]\S*?\s)[A-Z0-9]{4}\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d\\d(?=\\S*?[A-Z]\\S*?\\s)[A-Z0-9]{4}\\s', 'gm')
const str = `AT exempt acc to ยงยง 4 Nr. 1A UStG iVm 6 USTG
254,49/100L 977,23
159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%
Commodity Code :
159C5F Magnatec St-St 0W-30 D, 20L E4
159432 Magnatec St-St 0W-30 D, 20L E4 --> Number only.
1AAAAA Magnatec St-St 0W-30 D, 20L E4 --> Starts with one digit.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}