use strict;
my $str = 'AT exempt acc to §§ 4 Nr. 1A UStG iVm 6 USTG
254,49/100L 977,23
159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%
Commodity Code :
159C5F Magnatec St-St 0W-30 D, 20L E4
159432 Magnatec St-St 0W-30 D, 20L E4 --> Number only.
1AAAAA Magnatec St-St 0W-30 D, 20L E4 --> Starts with one digit.';
my $regex = qr/\b\d\d(?=\S*?[A-Z]\S*?\s)[A-Z0-9]{4}\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}