import re
regex = re.compile(r"\b\d\d(?=\S*?[A-Z]\S*?\s)[A-Z0-9]{4}\s", flags=re.MULTILINE)
test_str = ("AT exempt acc to ยงยง 4 Nr. 1A UStG iVm 6 USTG\n"
" 254,49/100L 977,23\n"
"159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%\n"
"Commodity Code :\n\n\n"
"159C5F Magnatec St-St 0W-30 D, 20L E4\n"
"159432 Magnatec St-St 0W-30 D, 20L E4 --> Number only.\n"
"1AAAAA Magnatec St-St 0W-30 D, 20L E4 --> Starts with one digit.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")