using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s\S+?\$info_max_time\$";
string input = @"yolo _time<=$info_max_time$ (index=* OR index=_*) $threat_match_value$ [search _time=2022-09-26T11:17:12.000-07:00 index=threat_activity | head 1 | `makemv(orig_sourcetype)` | rename orig_sourcetype as sourcetype | mvexpand sourcetype | return 100 sourcetype]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}