const regex = /\s\S+?\$info_max_time\$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\S+?\\$info_max_time\\$', 'gm')
const str = `yolo _time<=\$info_max_time\$ (index=* OR index=_*) \$threat_match_value\$ [search _time=2022-09-26T11:17:12.000-07:00 index=threat_activity | head 1 | \`makemv(orig_sourcetype)\` | rename orig_sourcetype as sourcetype | mvexpand sourcetype | return 100 sourcetype]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}