re = /\s\S+?\$info_max_time\$/m
str = 'yolo _time<=$info_max_time$ (index=* OR index=_*) $threat_match_value$ [search _time=2022-09-26T11:17:12.000-07:00 index=threat_activity | head 1 | `makemv(orig_sourcetype)` | rename orig_sourcetype as sourcetype | mvexpand sourcetype | return 100 sourcetype]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end