using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Group:\s(\w+) \|SubGroup:\s(\w*)";
string input = @"Group: i_am_group |SubGroup: i_am_sub_group";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}