$re = '/Group:\s(\w+) \|SubGroup:\s(\w*)/m';
$str = 'Group: i_am_group |SubGroup: i_am_sub_group';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);