re = /Group:\s(\w+) \|SubGroup:\s(\w*)/m
str = 'Group: i_am_group |SubGroup: i_am_sub_group'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end