using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\bapple\b";
string input = @"John: I like eating banana. What's your favorite fruit?
Anne: I don't know. I guess I like eating apple.
Anne: I don't like pineapple or applepear.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}