// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)\bapple\b").unwrap();
let string = "John: I like eating banana. What's your favorite fruit?
Anne: I don't know. I guess I like eating apple.
Anne: I don't like pineapple or applepear.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}