use strict;
my $str = 'John: I like eating banana. What\'s your favorite fruit?
Anne: I don\'t know. I guess I like eating apple.
Anne: I don\'t like pineapple or applepear.';
my $regex = qr/(?i)\bapple\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}