re = /(?i)\bapple\b/m
str = 'John: I like eating banana. What\'s your favorite fruit?
Anne: I don\'t know. I guess I like eating apple.
Anne: I don\'t like pineapple or applepear.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end