using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)";
string substitution = @"$1$2$3$4, 1$5";
string input = @"internal CruiserTorpedo(Player owner) : this(owner, "") {
}
internal CruiserTorpedo(string name) : base(""Torpedo Cruiser"",
new UnitDimensions(4),
new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },
Armor.Light, Surface.Water, name) {
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}