import re
regex = re.compile(r"(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)")
test_str = ("internal CruiserTorpedo(Player owner) : this(owner, \"\") {\n"
" }\n\n"
" internal CruiserTorpedo(string name) : base(\"Torpedo Cruiser\",\n"
" new UnitDimensions(4),\n"
" new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },\n"
" Armor.Light, Surface.Water, name) {\n"
" }")
subst = "$1$2$3$4, 1$5"
result = regex.sub(subst, test_str)
if result:
print(result)