$re = '/(?i)<(\/?\b(?:span|a|input|div|i|b|s|u|br|li|ul|ol|small|img|body|html|head|h[1-6]|title|em)\b[^>]*)>/m';
$str = '<span class="avatar2-default bg-dark rounded-circle">
<a href="">Hello</a>
<i>Hello</a>
<s>Hello</a>
<h1>Hello</h1>
<input type=
"text">
</span>
<>
<<
>>
</>';
$subst = "<$1&t;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;