// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)<(\/?\b(?:span|a|input|div|i|b|s|u|br|li|ul|ol|small|img|body|html|head|h[1-6]|title|em)\b[^>]*)>").unwrap();
let string = "<span class=\"avatar2-default bg-dark rounded-circle\">
<a href=\"\">Hello</a>
<i>Hello</a>
<s>Hello</a>
<h1>Hello</h1>
<input type=
\"text\">
</span>
<>
<<
>>
</>";
let substitution = "<$1&t;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}