#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[b](?!\s*\[/b])\s*(.+?)\s*\[/b]"
Local $sString = "[b]text[/b]" & @CRLF & _
"[b] " & @CRLF & _
"text [/b]" & @CRLF & _
"[b] text " & @CRLF & _
"text2 [/b] [b] [/b]" & @CRLF & _
"" & @CRLF & _
"[b] " & @CRLF & _
" [/b]" & @CRLF & _
"[b][/b]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")