$re = '~\[b](?!\s*\[/b])\s*(.+?)\s*\[/b]~s';
$str = '[b]text[/b]
[b]
text [/b]
[b] text
text2 [/b] [b] [/b]
[b]
[/b]
[b][/b]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);