re = /\[b](?!\s*\[\/b])\s*(.+?)\s*\[\/b]/
str = '[b]text[/b]
[b]
text [/b]
[b] text
text2 [/b] [b] [/b]
[b]
[/b]
[b][/b]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end