import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[b](?!\\s*\\[/b])\\s*(.+?)\\s*\\[/b]";
final String string = "[b]text[/b]\n"
+ "[b] \n"
+ "text [/b]\n"
+ "[b] text \n"
+ "text2 [/b] [b] [/b]\n\n"
+ "[b] \n"
+ " [/b]\n"
+ "[b][/b]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}