import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]+ place=\"(?!downward\").*?\"[^>]*>";
final String string = "<xml:jus id=\"84\" trek=\"spanned\" place=\"downward\">\n"
+ "<xml:jus id=\"84\" trek=\"spanned\" place=\"upward\">\n"
+ "<xml:jus id=\"84\" trek=\"spanned\" place=\"New York\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}