using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data-(?:token|ad-id)=""(.+)""";
string input = @"<div class=""suggesttext tleft"">
<a href=""#"" class=""link clearPhoneViews""
data-token=""eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhZElEIjoiNDU4MTI0NjQ2IiwiZXhwIjoxNTQyNDkxMzAxfQ.sJsVtqm9KyUWXlKHmaTtz43rQzWeVH0ZQSpe8NVpj7A""
data-ad-id=""458124646"">
<span>Обнулить</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}