package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)data-(?:token|ad-id)="(.+)"`)
var str = `<div class="suggesttext tleft">
<a href="#" class="link clearPhoneViews"
data-token="eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhZElEIjoiNDU4MTI0NjQ2IiwiZXhwIjoxNTQyNDkxMzAxfQ.sJsVtqm9KyUWXlKHmaTtz43rQzWeVH0ZQSpe8NVpj7A"
data-ad-id="458124646">
<span>Обнулить</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}