re = /data-(?:token|ad-id)="(.+)"/m
str = '<div class="suggesttext tleft">
<a href="#" class="link clearPhoneViews"
data-token="eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhZElEIjoiNDU4MTI0NjQ2IiwiZXhwIjoxNTQyNDkxMzAxfQ.sJsVtqm9KyUWXlKHmaTtz43rQzWeVH0ZQSpe8NVpj7A"
data-ad-id="458124646">
<span>Обнулить</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end