using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:custpartnum).*(?:8798518684708)(?!.*filtered).*";
string input = @"custpartnum-en-8798518684708.csv_20180612152233580
custpartnum-en-8798518684708.csv_filtered_20180612152300971";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}