import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:custpartnum).*(?:8798518684708)(?!.*filtered).*";
final String string = "custpartnum-en-8798518684708.csv_20180612152233580\n"
+ "custpartnum-en-8798518684708.csv_filtered_20180612152300971";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}