re = /(?:custpartnum).*(?:8798518684708)(?!.*filtered).*/m
str = 'custpartnum-en-8798518684708.csv_20180612152233580
custpartnum-en-8798518684708.csv_filtered_20180612152300971'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end