import re
regex = re.compile(r"(?:custpartnum).*(?:8798518684708)(?!.*filtered).*", flags=re.MULTILINE)
test_str = ("custpartnum-en-8798518684708.csv_20180612152233580\n"
"custpartnum-en-8798518684708.csv_filtered_20180612152300971")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")