const regex = /[?&\/]x=([^&\n]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?&\\\/]x=([^&\\n]*)', 'gm')
const str = `/abc/x=1+2&y=25&c=1
x=1+2&y=25&c=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}