// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[?&\/]x=([^&\n]*)").unwrap();
let string = "/abc/x=1+2&y=25&c=1
x=1+2&y=25&c=1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}