$re = '/[?&\/]x=([^&\n]*)/m';
$str = '/abc/x=1+2&y=25&c=1
x=1+2&y=25&c=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);