using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)\s(\S+)\s\bwas born on\b\s(\S+)\s(\S+),\s(\S+)";
string input = @"James Smith was born on November 17, 1948";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}