re = /(\S+)\s(\S+)\s\bwas born on\b\s(\S+)\s(\S+),\s(\S+)/
str = 'James Smith was born on November 17, 1948'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end