package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+)\s(\S+)\s\bwas born on\b\s(\S+)\s(\S+),\s(\S+)`)
var str = `James Smith was born on November 17, 1948`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}