$re = '/(\S+)\s(\S+)\s\bwas born on\b\s(\S+)\s(\S+),\s(\S+)/';
$str = 'James Smith was born on November 17, 1948';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);