using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d){1,2}\/(\d){1,2}\/(\d){1,4}\s(\d){1,2}:(\d){1,2}:(\d){1,2}\.(\d){1,8}\s\[(?<host>.*?)\]\sTook\s+(?<NumSources>\d+)\s+sources\s+(?<seconds>(\d+\.\d+|\d+))\s+seconds\sto\scollect\s(?<numlogs>\d+)\s+logs\s+\-\s+avg\s(?<avg>(\d+\.\d+|\d+)).*?$";
string input = @"09/29/2019 00:00:01.989966 [CHR2PR2SC62] Took 0 sources 0.0000 seconds to collect 0 logs - avg 0.00 logs/sec
09/29/2019 01:51:42.517856 [CHR2PR2SC62] Took 1 sources 1.1326 seconds to collect 8000 logs - avg 7063.51 logs/sec
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}