import Foundation
let pattern = #"^(\d){1,2}\/(\d){1,2}\/(\d){1,4}\s(\d){1,2}:(\d){1,2}:(\d){1,2}\.(\d){1,8}\s\[(?<host>.*?)\]\sTook\s+(?<NumSources>\d+)\s+sources\s+(?<seconds>(\d+\.\d+|\d+))\s+seconds\sto\scollect\s(?<numlogs>\d+)\s+logs\s+\-\s+avg\s(?<avg>(\d+\.\d+|\d+)).*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
09/29/2019 00:00:01.989966 [CHR2PR2SC62] Took 0 sources 0.0000 seconds to collect 0 logs - avg 0.00 logs/sec
09/29/2019 01:51:42.517856 [CHR2PR2SC62] Took 1 sources 1.1326 seconds to collect 8000 logs - avg 7063.51 logs/sec
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)